TIGMINT – OSINT GUI software framework

TIGMINT

TIGMINT : Twitter, Instagram and Geo-Tagging Media Intelligence


Introduction

An OSINT (Open Source Intelligence) software framework with an objective of making cyber investigations more convinient by implementing abstraction mechanisms to hide the background technical complexity also bundling different analysis techniques for social media Intelligence together providing a simple intuitive web interface for the user to work with.

Preview

Preview

Modules

Modules

Our Team

Our Team

Documentation

Documentation

Account Finder

Account Finder

Twitter Analyser

Twitter Analyser

Local Setup

Requirements

  • Python 3.6;
  • beautifulsoup4;
  • Nodejs;
  • matplotlib;
  • pandas;
  • NPM;
  • nltk;

Windows Setup Issues

For windows users, if the setup fails or application is redirecting to 404 error page always. You can verify the below steps.

  1. Verify all the modules in requirements.txt are successfully installed using pip3 install -r requirements.txt Command . In windows you have to manually install wordcloud module based on your python version.
    WordCloud module download Link   |   StackOverflow Help Thread
    Ex: If you had python 3.6 installed, then you have to install wordcloud‑1.8.0‑cp36‑cp36m‑win_amd64.whl module from the above link.
    After installing the wordcloud module, run command pip install -r requirements.txt again to check if all requirements are installed successfully.
  2. Check if all Node requirements are installed using npm install command.

If you still had any problems please open a issue with module name, operating system, input and output and console log. We will try to fix the issue as soon as possible.

Linux Meta-Analysis Requirment

sudo apt install exiftool

The above tool is required to retreive metadata from various file formats.

Installing and running

Git:

git clone https://github.com/TIGMINT/TIGMINT
cd TIGMINT
pip3 install -r requirements.txt
pip3 install --user --upgrade git+https://github.com/twintproject/twint.git@origin/master#egg=twint

npm install
node Api/server.js

Tool not working?

  1. Update python dependencies. (pip3 install –user –upgrade git+https://github.com/twintproject/twint.git@origin/master#egg=twint)
  2. Reinstall from the github repo.
  3. Raise an issue with the error logs. We will fix it asap !.

Using Docker

you can run with docker with this command

docker run --name tigmint -p 3000:3000 k1m0ch1/tigmint

and open the http://localhost:3000

or you can build the image by yourself with command

docker build -t tigmint .

Note

Meta Analysis module is not yet integrated into the web application.

Suggestions, Comments, Feedback

Feedback or new tool suggestions are extremely welcome! Please feel free to submit a pull request or open an issue on github